Application Error

Incident Report for Ownr

Resolved

All Ownr applications are functioning normally and the incident is now resolved.
Posted Jun 10, 2025 - 20:31 EDT

Monitoring

A fix has been implemented. Service to all Ownr applications has been restored.

We are continuing to monitor for errors.
Posted Jun 10, 2025 - 19:06 EDT

Identified

Ownr services are currently unavailable due to an outage with our web hosting provider.

We are in communication with the provider and are working with them to resolve the incident. We will provide further updates as we receive more information.
Posted Jun 10, 2025 - 10:25 EDT

Investigating

Ownr users are currently experiencing issue logging in to ownr.co.

We are investigating the issue and will update shortly with more information.
Posted Jun 10, 2025 - 09:35 EDT
This incident affected: Web & Application.