Error Processing Nuans Reports
Incident Report for Ownr
Resolved
The incident has been resolved and all outstanding Nuans reports have now been processed.
Posted Jul 23, 2024 - 14:48 EDT
Investigating
Due to an outage with the Nuans Platform, we are currently unable to process requests for Nuans reports. We are communicating with their team to resolve the issue and will provide an update once we have more information.

This will affect named incorporation requests for companies based in Alberta and Ontario (for corporations registering both provincially and federally).
Posted Jul 23, 2024 - 10:43 EDT
This incident affected: Registry Services (NUANS).