Delays with Federal Filings
Incident Report for Ownr
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 14:01 EST
Identified
Most federal filings are being completed according to normal timelines.

Some incorporation requests may still take longer than typical to be processed. We are continuing to work towards implementing a solution for those impacted.
Posted Oct 30, 2024 - 17:29 EDT
Update
We are continuing to investigate this issue.
Posted Oct 24, 2024 - 09:08 EDT
Investigating
We are currently experiencing issues processing Federal Registrations.
Users may experience delays with all federal filings.
Posted Oct 22, 2024 - 15:58 EDT
This incident affected: Registry Services (Corporations Canada).