Delays with Federal Incorporations

Incident Report for Ownr

Resolved

This incident has been resolved. All submissions should now be processed within normal timelines.
Posted May 24, 2024 - 11:33 EDT

Monitoring

A fix has been implemented. Previously submitted requests will be processed within 2-3 business days.
Posted May 22, 2024 - 15:11 EDT

Identified

Federal Corporations may experience delays due to recent updates with Corporations Canada's online filing centre.

We are working to resolve the issue and hope to have all systems restored as soon as possible.
Posted May 16, 2024 - 14:16 EDT
This incident affected: Registry Services (Corporations Canada).