Ownr site & app unavailable

Incident Report for Ownr

Resolved

This incident has been resolved.
Posted Jan 19, 2022 - 11:03 EST

Investigating

We are currently investigating this issue.
Posted Jan 19, 2022 - 09:36 EST
This incident affected: Web & Application.