The BC Registries have resumed normal operations. However, Ownr users should expect continued delays while the BC Registry processes their backlog of Name Requests.
Posted Oct 29, 2025 - 12:03 EDT
Identified
Name requests for companies in British Columbia are not currently being processed due to the temporary closure of the BC Registries. The closure is a result of ongoing job action affecting multiple government ministries.
Note that numbered incorporations, companies with an existing approved named request, and any post-incorporation filings are not impacted.
We apologize for the inconvenience and will update as new information becomes available.
Posted Sep 24, 2025 - 11:51 EDT
Investigating
Name requests for companies in British Columbia are not currently being processed due to the temporary closure of the BC Registries.
Posted Sep 24, 2025 - 11:50 EDT
This incident affects: Registry Services (BC Corporate Services).