Delays with the Ontario Business Registry
Incident Report for Ownr
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 16:12 EDT
Identified
The Ontario Business Registry is currently experiencing issues processing requests.

Some Provincial Ontario filings may take longer than usual to complete.
Posted Oct 16, 2024 - 10:11 EDT
This incident affected: Registry Services (Ontario Corporate Services).