Ownr Service Interruptions

Incident Report for Ownr

Resolved

All Ownr systems are functioning as normal.
Posted Jun 12, 2025 - 17:07 EDT

Monitoring

Access to Ownr services has been restored.

We continue to monitor systems for any outstanding issues.
Posted Jun 12, 2025 - 16:33 EDT

Identified

Service interruptions with Ownr services have been confirmed to be caused by an outage with an external service provider.

Ownr is in communication with the service provider and working to resolve the issue.

We will continue to provide updates as we receive more information.
Posted Jun 12, 2025 - 14:47 EDT

Investigating

Ownr is currently experiencing systems interruptions. We are aware of the incident and currently investigating.

We will provide updates once we have more information.
Posted Jun 12, 2025 - 14:18 EDT
This incident affected: Web & Application.